[texpoint-users] a weird error message

Eric Phipps etphipp at sandia.gov
Wed Oct 25 15:49:19 PDT 2006

I just wanted to mention that I just recently came across the same error
with TexPoint (latest version, 2.12) and Office 2004 on the Mac.  I suspect
the problem is FileVault related because I too use FileVault (mandated by
the company I work for).  I tried setting the TexPoint working directory in
the Configuration dialog to be something not in my home directory (e.g.,
/tmp/texpoint) that I have write access to, but that didn't work.  However
what did work was making a sym-link from /Volumes/etphipp to /Users/etphipp.

As far as I am aware, home directories are always in /Users on OS X.  So why
do you prepend /Volumes to the directory?


> -----Original Message-----
> From: users-bounces at lists.texpoint.necula.org
> [mailto:users-bounces at lists.texpoint.necula.org] On Behalf Of
> Lie-Quan Lee
> Sent: Monday, March 27, 2006 9:27 PM
> To: Andreas Glatz
> Cc: users at lists.texpoint.necula.org
> Subject: Re: [texpoint-users] a weird error message
> On 3/27/06 9:20 PM, "Andreas Glatz" <glatz at anl.gov> wrote:
> > Lie-Quan Lee wrote:
> >> I guess that it the because the path returned from PP is
> not usable 
> >> in the AppleScript due to FileVault.
> > I have to admit that I never used FileVault, but I thought it just
> > encrypts the home folder, but you do not actually see a
> difference in 
> > the Finder...
> > (I use an encrypted dmg file, which seems to be much more
> flexible to me).
> I strongly suspect it is FileVault because quite a few things
> doe not work well any more after I started to use it. I
> regret to use it but I cannot go back (no space to convert it back).
> >> The full message of running that ptest is:
> >> Path: llee:Desktop
> >> Name: ptest.ppt
> >> FullName: llee:Desktop:ptest.ppt
> >> file found
> > That is interesting. For VBA file operations the path seems
> to be ok, 
> > but I have to "translate" it to a UNIX path for latex & Co.
> TexPoint 
> > does this by replacing the colons by "/" and adding a
> "/Volumes/" in 
> > front of it - maybe this is the reason that this translated
> path does 
> > not work in your case.
> > (does "cd /llee" work in a Terminal shell?)
> No, "cd /llee" does not work in terminal. You are right, that
> translation does not work because there is no /Volumes/llee.
> > In the next version, one can define a temporary working
> directory for 
> > external commands. That should solve the problem. My plan is to
> > release it during the next two weeks.
> That is a good idea. Thanks and I am looking forward to your
> next release.
> --Rich
> _______________________________________________
> users mailing list
> users at lists.texpoint.necula.org
> http://lists.texpoint.necula.org/listinfo.cgi/users-texpoint.n

More information about the users mailing list